Active "Ice Cream ROM for Adam" Thread

I started something here:
http://www.tabletroms.com/forums/ice...-etcetera.html

not sure how this wiki thing works. [Skeeve 01/03: Quite easy just hit the edit tab :) ... and then the save push button below afterwards. Here you can find some more information on how to use the wiki]

I will try to update this list with your suggestions and tips and tricks that pop up in the main thread.

Before posting to the forum please first check the Github!

FAQ for ics beta etcetera
Since a lot of questions get asked more then once I wanted to start a FAQ. So this is my first attempt. Feel free to add.
It would be great if subsequent posts are related to the FAQ.

[top]general:

[top]Nice a FAQ. my question is not on it however, what do I do?

go here and read the first post.
use the search function,or just read al the pages
read other forum threads
go to the github on the page mentioned above.
if you are sure it is a new question, then post it. be prepared to be ignored of you did not research your question before posting.

[top]installation:

[top]how do I flash the new ICS rom?

go here and read the first post.
do not forget to wipe thoroughly before you flash. it is advised to even wipe your sd card. but make a backup of your files first!

[top]Do I need to use nvflash?

Yes, first nvflash to update the size of your system partitions.
when installing a new beta on top of an old beta, this is not neccesary, unless you are getting weird problems

[top]my computer does not recognize my adam?

have you installed the drivers included in the download called: CM9-ADAM-BETA-AIO

[top]drivers?? what are they, or how do i update them?

please find someone to help. it is more than likely that you do not have the skills to do an update.
but if you still want to try: open the device manager, right click on the not recognized adam device, update drivers and browse to the directory where you unzipped the nvflash update and find the drivers. (windows version)
also read this post

[top]can i flash beta2.zip only?

no you need to nvflash first, the use the recovery to flash the beta3.zip

[top]something went wrong, my adam is not booting, things are missing, i have strange behaviour.

try wiping everything again. did you nvflash? did you flash the follow up beta?

[top]What cable should i use to connect my ADAM

this is a mini usb cable that you plug into the left side of the adam. people have reported that you need a good quality cable.
so be sure to check your cable in case of connection problems

[top]performance is slow after updating

Yes, market is trying to sync over the internet. this slows down the ADAM. speed should pick up after an hour or so. go do something else.

[top]performance improved, but then slowed down again

what did you install?
f.e. launcher EX is known to slow things down.
a workaround could be to increase the minimum frequency in the performance settings

[top]I can not unlock after installation

try rebooting

[top]oops, something is really wrong. you killed my ADAM

we did no such thing. you do this on your own responsibility.
first try to reboot with the reset button. if that does not work, try shutting down by holding down the power button for a few seconds. then restart.
try going through the flash procedure again. this might sound silly but it does work sometimes.
if nothing works:
it is best to return to stock NI rom and retry. remember to use nvflash, there is a thread with available roms. search for it, if you need it.
(thanks again MRDeadLocked)



[top]Bugs

[top]I have a bug should I posts this?

all experiences are welcome. but think before you post! is the bug already mentioned on github? than it is a known bug.You might want to spent your time on something more usefull

[top]my bug is not in this list?

check the github!

[top]When I bungyjump your rom does not work

Not all usercases are relevant. use some common sense when reporting. is there a quick workaround, or is it something a lot of users will find problematic?
then post it. else: live with it, there are more serious problems that need solving.
(off course this could be a bug in the accelerometer, in which case we want to hear about it)

[top]My battery does not charge up to 100%

this is not a bug, but a design choice. however since so many people are reporting it as a bug, it will be changed. in the mean time try deleting your battery stats in the recovery, or with an app.
will probably not work, but hey, it does no harm trying.
also the percentages are missing from the launcher screen. find an app for that!!

[top]I cannot find my microsdcard in the adam

try using a file explorer like filemanager HD. they can show all storage locations.
did you look under the internal sd card? they are swapped around

[top]My adam does not wake up

try giving it some coffee.
or... either press the powerbutton once or twice, maybe a bit longer.
not working? press the hardware back button a few times. hold it for a bit longer than a short press.
not working? try all options again.
if all else fails: press the reset button, wait for a bootscreen, hold down the powerbutton until the power shuts off, then reboot.
(just rebooting with the reset button sometimes seems to generate an error. however try it first and when an error occurs, shutdown your adam and reboot)

[top]I have 3G problems

Borkata has done a lot of work on it for beta3.
still not working? post your problem in the thread or github

[top]my game/app is not working properly

is it the game/app, or is it the rom? do not expect everything to work. it is a new os, so things might not work in the end

[top]My red light is on

Yes, that is supposed to be on. works a bit different than before, but is not a bug.

[top]kindle is not working

long press and download the book seems to work. (Skeeve 01/03: Somebody reported that issue is gone on the newest kindle update from the market)


[top]video playback

[top]720p or higher video does not play

dice player gives the best result
but think about it: why do you want to play HD content on an ADAM screen? it just does not make sense.

[top]I cannot play HDMI

other people can.

[top]flash video is not playing

did you install flash?
try another browser like opera or skyfire.

[top]I do not like the bootanimation

So change it. there is an app for that. (or you can replace the bootanimation manually in /system/media folder. use a filemanager with root access)
or you can put animation.zip in /data/local.
there is even an app that gives you verbose boot if you want to be all nerdy. (live dmsg lite)


[top]new roms

[top]when are new roms expected, beta3, beta4, beta 5?

when they are done. current release schedule is once every 1.5 weeks on average.

[top]when do we get a rom with a working camera

if it was easy, it would already have been included. the elves are working on it.

[top]Which updates can we expect from the next rom

whatever problems get solved. check the github for an idea.

[top]Tweaks & Tips

[top]Installing a new Bootanimation

The article can be found here with more information and tons of animations ...
- Download an apk such as Root Explorer (there are others that are free and do the same)
- Go to /System/Media (many file managers would not see the system folder)
- Note: An alternative would be to put it in /data/local (Thanks aman9393). That way you can keep your original!
- Drop bootanimation.zip into the Media folder. Do not extract it or anything.
- permissions to rw-r--r--

[top]Dis-/ Enableing Bootanimation

[Skeeve 6.3.: I will test it and report here / Skeeve 15.03 The first one worked out for me]

Try this on first:

If you did turn bootanimation off in previous built then it's possible it stayed turned off when you switched to newer alpha. there is a fix (this is shamelessly copied from somebody else on Rootzwiki)

maybe you still have the setting on ("persist.sys.nobootanimation"):
root@android:/ # ls -la /data/property
ls -la /data/property
-rw------- root root 8 2011-12-01 15:35 persist.cf3d.nightmode
-rw------- root root 0 2012-01-26 09:23 persist.service.adb.enable
-rw------- root root 1 2011-10-28 20:46 persist.sys.alarm-attn
-rw------- root root 2 2012-01-01 11:52 persist.sys.country
-rw------- root root 2 2012-01-01 11:52 persist.sys.language
-rw------- root root 0 2012-01-01 11:52 persist.sys.localevar
-rw------- root root 1 2012-02-18 14:47 persist.sys.nobootanimation <---------- this one
-rw------- root root 1 2011-10-28 20:46 persist.sys.notif-attn
-rw------- root root 1 2012-02-19 15:09 persist.sys.profiler_ms
-rw------- root root 1 2011-10-28 20:46 persist.sys.ring-attn
-rw------- root root 0 2011-11-27 11:47 persist.sys.themeId
-rw------- root root 0 2011-11-27 11:47 persist.sys.themePackageName
-rw------- root root 13 2011-10-26 17:26 persist.sys.timezone
-rw------- root root 5 2012-01-19 14:16 persist.sys.ui.hw
-rw------- root root 7 2012-02-20 18:37 persist.sys.usb.config
-rw------- root root 1 2012-02-12 19:50 persist.sys.use_dithering
-rw------- root root 3 2011-11-05 14:15 persist.sys.vm.heapsize
root@android:/ #

Just delete the file and restart

root@android:/ # rm /data/property/persist.sys.nobootanimation
rm /data/property/persist.sys.nobootanimation
root@android:/ # su

... and if it is not working this one:

Make sure to Backup Nandroid before playing with Build.prop

#Disable Boot Animation

debug.sf.nobootanimation=0

[top]Installing Youtube

Just download it from here, go with your explorer to the download folder and click on it to install it.

[top]Using eMMC for storage in absence of external SD card

save this in a script file, e.g. swap_sd.sh, then run it from inside adam.
Code:
#!/bin/bash
# swap emmc and sdcard mount points
echo swapping emmc and sdcard mount points...
mount -o rw,remount -t yaffs2 /dev/block/mtdblock3
sed -i 's/3\/mmc_host\/mmc1/2\/mmc_host\/mmc2/g' /system/etc/vold.fstab
sed -i 's/sdcard auto \/devices\/platform\/sdhci-tegra.2\/mmc_host\/mmc2/sdcard auto \/devices\/platform\/sdhci-tegra.3\/mmc_host\/mmc1/g' /system/etc/vold.fstab
echo swap done.
You may have to re-run it every time you flash an update.

Tags for this Page

Posting Permissions

Posting Permissions
  • You may not create new articles
  • You may not edit articles
  • You may not protect articles
  • You may not post comments
  • You may not post attachments
  • You may not edit your comments