Hi Albert, I just bought my NT yesterday, I have checked my settings and the sofware is version 1.4.1 will buying one of your SD cards work for me? Also does the SD card method void the warrinty?...