Page 1 of 2 12 LastLast
Results 1 to 10 of 18

Thread: Bad Digitizer on Prestige 7L? Or bad update?

  1. #1
    Member ahicks66's Avatar
    Join Date
    Jul 2013
    Location
    Salem, CT
    Posts
    10
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Unhappy Bad Digitizer on Prestige 7L? Or bad update?

    Hey everybody... I have a Prestige 7L that I've owned for... Wow, four months, running completely stock. It's worked quite well for the most part, I'm no super user by any stretch of the imagination, and it's done pretty much what I needed it to do.

    Until this weekend... When I went to use the tablet and realized I left it on standby for too long and the battery went dead. OK, no problem, I plug it in and let it get a full uninterrupted charge. When it's done, I power it up, and it boots, auto-connects to my router, and then it pops up with a notice of a system update. It does the update, reboots, gets to the main window where I have to touch to unlock it... And I get no response at all from the touch. Not only does it no longer show the touch point as I had it set up, nowhere on the screen responds to any touch whatsoever. The screen otherwise looks great, no sign of damage (and I've babied this sucker, too). Even better, it no longer connects to my wireless extender sitting 4 feet away, and it also does not connect to my main router, in fact, "No Connection Available" shows in the taskbar.

    I've tried many times to get into the setup screen - I have only been able to do so successfully once. Three other times I got to the Android Service Icon (the one with the door swung open and a triangle with exclamation point) and no further. I'm a total noob with tablets, Android, and Linux. I went to a technical school fresh out of high school - my education is from Win 3.11 and DOS 6.22 to Win '95... Pentium 1 was just hitting the main marketplace, USB was some incredible thing they were working on, Plug and Play was nicknamed "Plug and Pray," and I was a Mac Plus thru Performa/LC Series (System 6 thru 7.5) guru... There were two types of RAM (in SIMMS - Single Inline Memory Modules): PC and MAC. I remember how hard it was to fill a 250 MEGABYTE hard drive... PATA was called IDE... So this new-fangled stuff totally eludes me.

    Being that my tablet worked wonderfully up to that random system update, I *DOUBT* the digitizer is bad. It sounds more like a driver-type issue to me... But again, I have no clue where to start.

    It's under manufacturer warranty, and the Walmart warranty won't cover it because the manufacturer warranty is still in effect. If it is the screen, no biggie, I'll deal with VL directly. If it's a software issue that I may be able to fix, I would prefer to do it myself and save the hassle of shipping and being without my tab...

    Any assistance you guys could give me would be invaluable! Thanks!

    --Andy

  2. #2
    Member ahicks66's Avatar
    Join Date
    Jul 2013
    Location
    Salem, CT
    Posts
    10
    Thanks
    0
    Thanked 0 Times in 0 Posts
    It's been 57 hours since I emailed Visual Land, haven't gotten a response yet... Anyone have any ideas on how I can un-brick this thing before I put it up for sale? I can't believe I wasted money on this tablet with a useless warranty, and wasted money on a useless protection plan that WalMart refuses to honor since it's under manufacturer warranty. First-time tablet buyer, and probably the last time too. Ridiculous. Haven't been able to use this thing for two weeks and can't find any help on the 'Net.

  3. #3
    TR ELITE TEAM Macktion's Avatar
    Join Date
    Jul 2011
    Location
    Utah, USA
    Posts
    986
    Thanks
    156
    Thanked 175 Times in 91 Posts
    Reflash your tablet.
    Follow the video and written instructions
    There are no solutions, only tradeoffs. -Thomas Sowell

    If you Like what I do, supply me with Tang.

  4. #4
    Veteran
    Join Date
    Apr 2012
    Posts
    1,277
    Thanks
    20
    Thanked 199 Times in 152 Posts
    There is a couple of things. This system does not auto update. So the system update message is suspect. What specifically did it say? Was it counting down files?

    As Macktion suggests a reflash would be your first place to start.

    But I wouldn't be counting hours for an e-mail reply. Based on what you give as your experience with CE you know that a response within two weeks back then was considered 5 star service. A week is a good average now. But e-mail even with the best of companies is a sucker bet still even with the biggest company out there. Calling is the best way to try to communicate with a company.
    If you like my work please feel free to DONATE

    If I do not answer your Private Message please do not assume I am ignoring you. I probably am, but assuming is rude.

    Skytex 10s Rabid ROM v1
    Skytex 7s Rabid ROM v1
    Dell Venue 8 Rooted and Deodexed
    Kindle Fire HDX 8.9 Rooted
    Kindle Fire HD 7 Rooted
    HP Touchpad 32GB Dual Boot WebOS & Cyanogen MOD 11
    Amazon FireTV Rooted
    Haier 9" Rooted
    Sero 7 Pro Rabid ROM Beta
    LePan TC1020 Rooted
    LePan TC802A Rooted - Deodexed

  5. #5
    Member ahicks66's Avatar
    Join Date
    Jul 2013
    Location
    Salem, CT
    Posts
    10
    Thanks
    0
    Thanked 0 Times in 0 Posts
    I have attempted to flash this device several times, and I have not had any luck with that either. I do not get an error from LiveSuit. I cannot even get the tablet to successfully connect to any computer.

    >>>
    1. Run Live Suit and select the IMG file you will be using to flash your tablet with
    2. Press the VOL+ button and hold it down as you connect your tablet to your computer via the USB
    3. While still holding down the VOL+ press the POWER button at least 10 times
    4. You should then hear the sounds your computer makes when a USB item is connected.
    5. You will be promted to select a method of flashing your tablet, you may now release the VOL+ button.
    >>>

    Step 4 never occurs, and neither does Step 5. I have tried various speeds and quantity of button presses with the same results. I've also followed the video to no avail. (Essentially same results - computer and LiveSuit don't seem to detect the tablet connected to the PC, and again, I've tried 3 different PCs.)

    This may have to do with the USB drivers linked in the flash instructions. I can't seem to do anything with *.7z files, and the ZIP link is suspicious (requires a subscription to download). Is this something I absolutely need, and if so, is there a better link for those drivers? I figured Windows Plug 'N' Pray could figure out the driver details... And it's always connected to the PC before I had issues with the screen.

    As far as the update happening... I've never seen it happen before. As soon as the tablet booted, before getting to the lock screen, a box popped up and said something along the lines of "Mandatory System Upgrade" and there was no way to cancel out of it. The box looked official enough, and although I'm a noob to Android, I know what to look for on Windows machines. This "Update" required no user interaction whatsoever, it's not like I clicked on one of those "Your Computer May Be Infected With A Virus!!" popups or the like.

    Is there a way to force a flash via microSD when the tablet has no functioning screen?

    I tried calling VL today, their customer service is only open M-F 8-5 Pacific Time (11-8 Eastern Time)... So I cannot explore that avenue yet.

  6. #6
    Veteran
    Join Date
    Apr 2012
    Posts
    1,277
    Thanks
    20
    Thanked 199 Times in 152 Posts
    Quote Originally Posted by ahicks66 View Post
    I have attempted to flash this device several times, and I have not had any luck with that either. I do not get an error from LiveSuit. I cannot even get the tablet to successfully connect to any computer.

    >>>
    1. Run Live Suit and select the IMG file you will be using to flash your tablet with
    2. Press the VOL+ button and hold it down as you connect your tablet to your computer via the USB
    3. While still holding down the VOL+ press the POWER button at least 10 times
    4. You should then hear the sounds your computer makes when a USB item is connected.
    5. You will be promted to select a method of flashing your tablet, you may now release the VOL+ button.
    >>>

    Step 4 never occurs, and neither does Step 5. I have tried various speeds and quantity of button presses with the same results. I've also followed the video to no avail. (Essentially same results - computer and LiveSuit don't seem to detect the tablet connected to the PC, and again, I've tried 3 different PCs.)

    This may have to do with the USB drivers linked in the flash instructions. I can't seem to do anything with *.7z files, and the ZIP link is suspicious (requires a subscription to download). Is this something I absolutely need, and if so, is there a better link for those drivers? I figured Windows Plug 'N' Pray could figure out the driver details... And it's always connected to the PC before I had issues with the screen.

    As far as the update happening... I've never seen it happen before. As soon as the tablet booted, before getting to the lock screen, a box popped up and said something along the lines of "Mandatory System Upgrade" and there was no way to cancel out of it. The box looked official enough, and although I'm a noob to Android, I know what to look for on Windows machines. This "Update" required no user interaction whatsoever, it's not like I clicked on one of those "Your Computer May Be Infected With A Virus!!" popups or the like.

    Is there a way to force a flash via microSD when the tablet has no functioning screen?

    I tried calling VL today, their customer service is only open M-F 8-5 Pacific Time (11-8 Eastern Time)... So I cannot explore that avenue yet.
    Make sure the tablet is powered off before trying step 2.

    .7z is zip just rename or download 7zip, it's a better compression program with more options anyway.

    Livesuit uses it's own drivers so that shouldn't be the issue.

    Phoenixcard has been linked in a few posts here. It will convert the image to a bootable microsd and flash that way.
    If you like my work please feel free to DONATE

    If I do not answer your Private Message please do not assume I am ignoring you. I probably am, but assuming is rude.

    Skytex 10s Rabid ROM v1
    Skytex 7s Rabid ROM v1
    Dell Venue 8 Rooted and Deodexed
    Kindle Fire HDX 8.9 Rooted
    Kindle Fire HD 7 Rooted
    HP Touchpad 32GB Dual Boot WebOS & Cyanogen MOD 11
    Amazon FireTV Rooted
    Haier 9" Rooted
    Sero 7 Pro Rabid ROM Beta
    LePan TC1020 Rooted
    LePan TC802A Rooted - Deodexed

  7. #7
    Member
    Join Date
    Sep 2012
    Posts
    2
    Thanks
    6
    Thanked 0 Times in 0 Posts
    I had the same problem! They never reply to emails even when you fill out the form..You have to call them...go to 411.com ? Official Site and look them up. I HAVE called them before...they are located in Cerritos, CA

  8. #8
    Member ahicks66's Avatar
    Join Date
    Jul 2013
    Location
    Salem, CT
    Posts
    10
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Mmmkay... I wanted to point out that I actually remembered to turn off the tablet before attempting a connection to the PC. Just to assist with troubleshooting.

    I tried using PhoenixCard numerous times... I get the rapid clicking and the "Feel Good Bar," which doesn't move, because above it printed in green are the following three lines (verbatim):
    "sprite update error: fail to scan flash information
    sprite update error: current card sprite failed
    now hold the machine"

    I feel pretty safe in assuming the third line isn't actually requesting that I physically hold the tablet... Even though it's phrased like a command to the user. Gotta have some technical meaning behind it, but I don't know what it is. :-/

    I'm going to download the FW again, just in case it got corrupted on download or by Livesuit. I've seen stranger things happen.

  9. #9
    Member ahicks66's Avatar
    Join Date
    Jul 2013
    Location
    Salem, CT
    Posts
    10
    Thanks
    0
    Thanked 0 Times in 0 Posts
    After messing around with this silly unit, and wasting 2 hours downloading another image file in the hopes that would get me somewhere... There has been absolutely no change.

    I was able to find something else out, which may or may not be useful. I got ticked because I couldn't get anything to work, so I hit the reset hole and tried rebooting that way... And EUREKA! I found the message about the update, it only lasts a few seconds when it pops up.

    "Android is upgrading..."

    There was a brief moment when it mentioned upgrading app 1 of 1...

    "Starting apps"

    Then - back to the lock screen, touch isn't working, no wireless connection available. So while I am still stuck with the original problem, I at least was able to get the exact message to pop up as it did when all my problems began.

    Also, after installing the image file to microSD, Windows reports my card as having 14.4 GB of 14.4 GB free, 48.0K used. I know Android is a small-footprint OS, but it seems to me that is waaaaay too low to be true if the image is on there. I have no visible files, either (other than error logs, which are text docs with the sprite errors on it as I typed in the previous message.

    I admit it, I like it when there are easy fixes to my problems, but I think that's mainly because there is seldom a simple solution to any of my problems. LOL!

  10. #10
    Regular
    Join Date
    Apr 2013
    Location
    South Carolina, USA
    Posts
    112
    Thanks
    6
    Thanked 15 Times in 11 Posts
    If you still have the short usb adapter cord, you can try connecting a mouse to the tablet and see if it responds that way. At the very least, it will let you know that at least the tablet is running.
    Visual Land Prestige 7L - Rabid-X Rom V1.1 Rev B
    Photobucket Library: http://s737.photobucket.com/user/xihuitl/library/
    Yahoo IM ID: bmwnfun

Page 1 of 2 12 LastLast

Remove Ads

Similar Threads

  1. Digitizer Glass REPLACEMENT PART!!
    By danb79 in forum Vega General Discussion
    Replies: 10
    Last Post: 08-31-2014, 07:05 AM
  2. Replies: 13
    Last Post: 02-13-2014, 01:13 PM
  3. Require a digitizer for an advent vega
    By Res in forum Vega ROM Development
    Replies: 5
    Last Post: 02-02-2013, 10:45 AM
  4. cracked digitizer
    By BIGIZZY in forum Prestige 7
    Replies: 5
    Last Post: 08-11-2012, 01:41 PM
  5. Adam as digitizer???
    By TheHardware in forum Adam General Discussion
    Replies: 6
    Last Post: 06-24-2011, 04:45 PM

Search tags for this page

digitizer driver android update
,

prestige 7 has no sound

,
prestige 7l glass
,
prestige 7l screen problem
,

prestige 7l update

,
problems with touchscreen on prestige 7l
,
replace touchscreen prestige 7l
,
visual land prestige 7 digitizer
,
visual land tablet android guy with triangle
,

will updating help my replacement digitizer problem

Click on a term to search for related topics.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •