Page 20 of 25 FirstFirst ... 101819202122 ... LastLast
Results 191 to 200 of 244

Thread: Success! 3G USB modems now work* on the Adam

  1. #191
    Regular
    Join Date
    Apr 2011
    Posts
    155
    Thanks
    88
    Thanked 59 Times in 19 Posts
    Quote Originally Posted by dune View Post
    Check the modem's LED. Before you run it, try 'stop ril-daemon'.
    I am using my own kernel now!
    Before inserting the modem I ussued "stop ril-daemon"
    Inserted the modem and the the dmesg output is -

    "<6>[ 1055.202717] usb 1-1.2: new full speed USB device using tegra-ehci and address 4
    <6>[ 1055.273211] usb 1-1.2: New USB device found, idVendor=19d2, idProduct=fff5
    <6>[ 1055.280288] usb 1-1.2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
    <6>[ 1055.287649] usb 1-1.2: Product: USB Storage
    <6>[ 1055.291882] usb 1-1.2: Manufacturer: ZTE, Incorporated
    <6>[ 1055.297269] usb 1-1.2: SerialNumber: 000000000002
    <6>[ 1055.305243] usb 1-1.2: configuration #1 chosen from 1 choice
    <6>[ 1055.313697] scsi0 : SCSI emulation for USB Mass Storage devices
    <7>[ 1055.326575] usb-storage: device found at 4
    <7>[ 1055.326598] usb-storage: waiting for device to settle before scanning
    <5>[ 1060.329379] scsi 0:0:0:0: CD-ROM ZTE USB Storage FFF1 2.31 PQ: 0 ANSI: 2
    <4>[ 1060.370130] sr0: scsi-1 drive
    <6>[ 1060.373295] Uniform CD-ROM driver Revision: 3.20
    <7>[ 1060.388594] sr 0:0:0:0: Attached scsi CD-ROM sr0
    <5>[ 1060.402780] sr 0:0:0:0: Attached scsi generic sg0 type 5
    <5>[ 1060.414599] scsi 0:0:0:1: Direct-Access ZTE USB Storage FFF1 2.31 PQ: 0 ANSI: 2
    <5>[ 1060.455361] sd 0:0:0:1: Attached scsi generic sg1 type 0
    <7>[ 1060.475492] usb-storage: device scan complete
    <5>[ 1060.479936] sd 0:0:0:1: [sda] Attached SCSI removable disk
    <4>[ 1060.643849] usb 1-1.2: usbfs: process 3189 (usb_modeswitch) did not claim interface 0 before use
    <6>[ 1060.842388] usb 1-1.2: USB disconnect, address 4
    <6>[ 1062.112659] usb 1-1.2: new full speed USB device using tegra-ehci and address 5
    <6>[ 1062.156552] usb 1-1.2: New USB device found, idVendor=19d2, idProduct=fff1
    <6>[ 1062.163468] usb 1-1.2: New USB device strings: Mfr=1, Product=2, SerialNumber=0
    <6>[ 1062.171313] usb 1-1.2: Product: ZTE CDMA Tech
    <6>[ 1062.175993] usb 1-1.2: Manufacturer: ZTE, Incorporated
    <6>[ 1062.184384] usb 1-1.2: configuration #1 chosen from 1 choice
    <6>[ 1062.194882] option 1-1.2:1.0: GSM modem (1-port) converter detected
    <6>[ 1062.205206] usb 1-1.2: GSM modem (1-port) converter now attached to ttyUSB0
    <6>[ 1062.216011] option 1-1.2:1.1: GSM modem (1-port) converter detected
    <6>[ 1062.225380] usb 1-1.2: GSM modem (1-port) converter now attached to ttyUSB1
    <6>[ 1062.234954] option 1-1.2:1.2: GSM modem (1-port) converter detected
    <6>[ 1062.243207] usb 1-1.2: GSM modem (1-port) converter now attached to ttyUSB2
    <6>[ 1062.251925] option 1-1.2:1.3: GSM modem (1-port) converter detected
    <6>[ 1062.259608] usb 1-1.2: GSM modem (1-port) converter now attached to ttyUSB3
    <6>[ 1062.267701] option 1-1.2:1.4: GSM modem (1-port) converter detected
    <6>[ 1062.276118] usb 1-1.2: GSM modem (1-port) converter now attached to ttyUSB4
    <6>[ 1062.283970] scsi1 : SCSI emulation for USB Mass Storage devices
    <7>[ 1062.292108] usb-storage: device found at 5
    <7>[ 1062.292116] usb-storage: waiting for device to settle before scanning
    <5>[ 1067.287000] scsi 1:0:0:0: Direct-Access ZTE USB Storage FFF1 2.31 PQ: 0 ANSI: 2
    <5>[ 1067.307576] sd 1:0:0:0: Attached scsi generic sg0 type 0
    <7>[ 1067.324193] usb-storage: device scan complete
    <5>[ 1067.329907] sd 1:0:0:0: [sda] Attached SCSI removable disk
    <3>[ 1068.514991] init: untracked pid 3239 exited"


    "lsusb" output indicatesthat the modem is attached!
    Bus 001 Device 001: ID 1d6b:0002
    Bus 001 Device 002: ID 0424:2514
    Bus 001 Device 003: ID 0bdb:190a
    Bus 001 Device 005: ID 19d2:fff1



    The "connect-error" file in the "/etc/ppp/connect-error shows-
    "Failed (NO CARRIER)
    abort on (BUSY)
    abort on (NO CARRIER)
    abort on (ERROR)
    abort on (+CME ERROR: 100)
    GPRS modem init: press <ctrl>-C to disconnect
    send (AT^M)
    expect (OK)
    ^M
    +CIEV: 2,3^M
    ^M
    +CIEV: 2,2^M
    ^M
    +CIEV: 2,3^M
    ^M
    +CIEV: 2,2^M
    ^M
    +CIEV: 2,3^M
    ^M
    +CIEV: 2,2^M
    ^M
    +CIEV: 2,3^M
    ^M
    +CIEV: 2,2^M
    ^M
    +CIEV: 2,3^M
    ^M
    +CIEV: 2,2^M
    ^M
    +CIEV: 2,3^M
    ^M
    +CIEV: 2,2^M
    ^M
    +CIEV: 2,3^M
    ^M
    +CIEV: 2,2^M
    ^M
    +CIEV: 2,0^M
    ^M
    +CIEV: 2,2^M
    ^M
    +CIEV: 2,3^M
    ^M
    +CIEV: 2,2^M
    ^M
    +CREG: 1,"0092","0000B3BD"^M
    ^M
    +CGREG: 1,"0092","0000B3BD",3^M
    ^M
    +CIEV: 2,3^M
    ^M
    +CIEV: 2,2^M
    ^M
    +CIEV: 2,3^M
    ^M
    OK
    -- got it

    send (AT^M)
    expect (OK)
    ^M
    ^M
    OK
    -- got it

    send (ATDT#777^M)
    expect (CONNECT)
    ^M
    ^M
    +CIEV: 2,2^M
    ^M
    NO CARRIER
    -- failed
    Failed (NO CARRIER)"


    The gprs-connect-chat script is as follows-
    #cat gprs-connect-chat
    ABORT 'BUSY'
    ABORT 'NO CARRIER'
    ABORT 'ERROR'
    ABORT '+CME ERROR: 100'
    SAY "GPRS modem init: press <ctrl>-C to disconnect\n"
    "" AT
    OK AT
    OK ATDT#777
    CONNECT


    The gprs script in /etc/ppp/peers/gprs is

    # cat gprs
    /dev/ttyACM0
    115200
    nocrtscts
    nocdtrcts
    local
    usepeerdns
    defaultroute
    noipdefault
    ipcp-accept-local
    ipcp-accept-remote
    user ********
    password ********
    debug
    kdebug 7
    #connect "/usr/sbin/chat -v -t 50 -f /etc/ppp/chat/cmtc-isp"
    connect "/system/bin/chat-ril -v -t 500 -s -f /etc/ppp/gprs-connect-chat"



    Any idea where its going wrong!!!!
    I am not understanding why in the dmesg last line it says <3>[ 1068.514991] init: untracked pid 3239 exited"
    Last edited by mbmad; 07-16-2011 at 12:53 AM.

  2. #192
    Resident
    Join Date
    Apr 2011
    Location
    India
    Posts
    875
    Thanks
    123
    Thanked 95 Times in 54 Posts
    Do I take it that the dialer worked for you earlier? Esp. the #777 number?

    Please see this thread on the usb_modeswitch forums. If you understand dialers and modem commands, see if it helps.

  3. #193
    Regular
    Join Date
    Apr 2011
    Posts
    155
    Thanks
    88
    Thanked 59 Times in 19 Posts
    Quote Originally Posted by dune View Post
    Do I take it that the dialer worked for you earlier? Esp. the #777 number?

    Please see this thread on the usb_modeswitch forums. If you understand dialers and modem commands, see if it helps.
    #777 worked earlier with WinnerGold's dirtyshot rom
    Thank you I will check out this on usb_modeswitch forums

  4. #194
    Administrator twospirits's Avatar
    Join Date
    Apr 2011
    Location
    NYC
    Posts
    655
    Thanks
    315
    Thanked 74 Times in 35 Posts
    Keep us posted.

    We are the Android, we will assimilate you.
    Want to make this place better, just ask the staff. Remember, the "No' is always there, you are just looking for the "Yes".
    Members, please read the Guidelines otherwise Banlandia awaits.

    Find me on Google + or twitter

  5. #195
    Regular
    Join Date
    Apr 2011
    Posts
    155
    Thanks
    88
    Thanked 59 Times in 19 Posts
    Quote Originally Posted by twospirits View Post
    Keep us posted.
    I have uploaded two roms adamcomb_v2 and beast 2.2.1 with 3G modem support
    1. for beast : http://tabletroms.com/forums/showthr...-modem-support
    2. For adamcomb: http://tabletroms.com/forums/showthr...with-USB-MODEM
    Hope these helps: I have added cifs and ntfs rw support too. But have not tested.
    In beast I could see my 160gb seagate ntfs drive (4 partions) is attaching but could not mount.
    Here is the dmesg output:
    <6>[ 1542.962109] usb 1-1.2: new high speed USB device using tegra-ehci and address 6
    <6>[ 1543.011894] usb 1-1.2: New USB device found, idVendor=0bc2, idProduct=2120
    <6>[ 1543.018897] usb 1-1.2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
    <6>[ 1543.026434] usb 1-1.2: Product: FreeAgent Go
    <6>[ 1543.030819] usb 1-1.2: Manufacturer: Seagate
    <6>[ 1543.035465] usb 1-1.2: SerialNumber: 2GE65KC0
    <7>[ 1548.096387] usb-storage: device scan complete
    <5>[ 1548.096943] sd 2:0:0:0: [sda] Write Protect is off
    <7>[ 1548.102514] sd 2:0:0:0: [sda] Mode Sense: 1c 00 00 00
    <3>[ 1548.102523] sd 2:0:0:0: [sda] Assuming drive cache: write through
    <3>[ 1548.112729] sd 2:0:0:0: [sda] Assuming drive cache: write through
    <6>[ 1548.118856] sda: sda1 sda2 sda3
    <3>[ 1548.185859] sd 2:0:0:0: [sda] Assuming drive cache: write through
    <5>[ 1548.197556] sd 2:0:0:0: [sda] Attached SCSI disk


  6. The Following 4 Users Say Thank You to mbmad For This Useful Post:

    atultiwari (07-17-2011), sandugandhi (07-22-2011), seamusgray (11-05-2011), twospirits (07-17-2011)

  7. #196
    Member
    Join Date
    Jun 2011
    Posts
    53
    Thanks
    8
    Thanked 1 Time in 1 Post
    thanx mbmad
    it works ..
    now can any1 help me out in following issues:
    1.reconnecting modem without restart
    2.make all google apps (eg.stock browser,market..etc)/other apps(few eg.engadget app,zenga tv..etc) recognize evdo internet some how?
    3.nothing more rest all is awsome!!

  8. The Following User Says Thank You to khonakr For This Useful Post:

    mohammadmobini (11-26-2011)

  9. #197
    Resident
    Join Date
    Apr 2011
    Location
    India
    Posts
    875
    Thanks
    123
    Thanked 95 Times in 54 Posts
    Updated version of the usb_modeswitch static ARM binary v1.1.9 can be downloaded from the website, along with the updated data package and the device reference file.

  10. The Following User Says Thank You to dune For This Useful Post:

    mohammadmobini (11-26-2011)

  11. #198
    Member
    Join Date
    Jun 2011
    Posts
    53
    Thanks
    8
    Thanked 1 Time in 1 Post
    dune can you tell me how do i update usb_modeswitch i already have mbmad's patch applied on Adamcomb 0.3 can you tell me steps asap...

  12. #199
    Resident
    Join Date
    Apr 2011
    Location
    India
    Posts
    875
    Thanks
    123
    Thanked 95 Times in 54 Posts
    just copy the files in place of the old ones on your tablet.

    usb_modeswitch (the precompiled binary) goes in /system/bin and the contents of usb_modeswitch.conf go in /system/data/usb_modeswitch

  13. #200
    Regular
    Join Date
    Apr 2011
    Posts
    155
    Thanks
    47
    Thanked 6 Times in 6 Posts
    @dune Whats the advantage of using the new usb nodeswitch files?
    Sorry for the question if you have mentioned this somehere already.

    Also the file links that you have given are tar.gz files. Should they be directly copied to the locations you mentioned or should they be unzipped or something?

    Cheers
    Last edited by sahakar; 08-15-2011 at 11:45 AM.
    My Mobile Gadgets Garage
    Original iPhone
    Moto XT720 running Cronox
    Notion Ink Adam LCD 3G - Jelly Bean
    Moto Atrix - Gingerbread
    LG Optimus 4X HD
    Nexus 7 - Jelly Bean

Page 20 of 25 FirstFirst ... 101819202122 ... LastLast

Remove Ads

Similar Threads

  1. Replies: 14
    Last Post: 10-28-2011, 03:50 AM
  2. Make OsmAnd work on Adam!!
    By pkiyengar in forum Adam General Discussion
    Replies: 8
    Last Post: 07-29-2011, 01:58 AM
  3. Where can I find apps that work on Adam free?
    By NoVation in forum Adam Frequently Asked Questions
    Replies: 3
    Last Post: 05-18-2011, 12:32 AM
  4. Does any qrcode reader work on Adam?
    By PsychodelEKS in forum Adam General Discussion
    Replies: 4
    Last Post: 05-14-2011, 03:22 PM
  5. Adam - What made it work for me.
    By brimin in forum Adam General Discussion
    Replies: 5
    Last Post: 05-05-2011, 10:59 AM

Search tags for this page

lw272 target vendor id

,
no default vendor/product id given
,
no default vendor/product id given. abort
,

no default vendor/product id given. aborting

,

no default vendor/product id given. aborting.

,
no ppp widget folder in sd card
,
unrecognized option /dev/ttyusb0
,
usb modeswitch android
,
usb modeswitch no default vendor/product id given. aborting
,
usb modeswitch no default vendor/product id given. aborting.
Click on a term to search for related topics.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •